Back
Downtime

https://speculare.cloud, auth.speculare.cloud/ping, https://dashboard.speculare.cloud, https://server.speculare.cloud/ping, https://cdc.speculare.cloud/ping, and 3 other services are down

Started 7 Jul at 03:15pm UTC, resolved 7 Jul at 03:20pm UTC.

Resolved

https://speculare.cloud, auth.speculare.cloud/ping, https://dashboard.speculare.cloud, and 2 other resources recovered.

Posted 7 Jul at 03:20pm UTC.
Created

https://speculare.cloud, auth.speculare.cloud/ping, https://dashboard.speculare.cloud, and 2 other resources went down.

Posted 7 Jul at 03:15pm UTC.