Back
Downtime

auth.speculare.cloud/ping, https://server.speculare.cloud/ping, https://cdc.speculare.cloud/ping, and 1 other service are down

Started 26 Jun at 12:04pm UTC, resolved 26 Jun at 12:40pm UTC.

Resolved

auth.speculare.cloud/ping, https://server.speculare.cloud/ping, and https://cdc.speculare.cloud/ping recovered.

Posted 26 Jun at 12:40pm UTC.
Created

auth.speculare.cloud/ping, https://server.speculare.cloud/ping, and https://cdc.speculare.cloud/ping went down.

Posted 26 Jun at 12:04pm UTC.