Back
Downtime

auth.speculare.cloud/ping and https://cdc.speculare.cloud/ping are down

Started 29 Jun at 06:42pm UTC, resolved 29 Jun at 06:49pm UTC.

Resolved

auth.speculare.cloud/ping and https://cdc.speculare.cloud/ping recovered.

Posted 29 Jun at 06:49pm UTC.
Created

auth.speculare.cloud/ping and https://cdc.speculare.cloud/ping went down.

Posted 29 Jun at 06:42pm UTC.